domingo, agosto 15, 2010

Puppy Linux 5.1 (Lucid Puppy) disponible

Hace tiempo, cuando fue liberado LUPU 5.0 (Lucid Puppy 5.0 o Puppy Linux 5.0), estuve probando durante casi un mes la distro en cuestión, pero por diferentes motivos no pude haceros un pequeño análisis de la misma.

Ahora Puppy Linux 5.1 ha sido lanzada, y esta vez no la dejo de lado, las diferencias estéticas, de funcionamiento, y distribución de los menús herramientas e iconos, con respecto a Puppy Linux 5.0, prácticamente no existen, a excepción del uso de un fondo mas psicodélico y moderno, y unos iconos mas sobrios, que renuncian al colorido en favor de la monocromía, con una tonalidad bastante uniforme que fluctúa entre el el gris claro y el oscuro.


Con Lucid Puppy 5.0, era la primera vez que la distribución Puppy Linux se basaba, al menos en parte, en la popular Ubuntu, dándole compatibilidad con sus binarios, y le ha venido bien, sigue siendo una distro superligera y rápida, y como se han basado en paquetes de Ubuntu, han tenido que hacer menos trabajo de cero... eso se nota en lo mucho que ha avanzado la distro (además, en la versión 5.0 comenzó a haber una comunidad implicada en el desarrollo, ya no es un sólo desarrollador)... es una distro muy trabajada y muy bien rematada, estuve probando la versión 5.0 unos días desde un pendrive, y luego la instalé en el discoduro durante unas semanas... y solo puedo decir que es una pequeña maravilla... aunque no tengas discoduro, puedes llegar a arrancarla en un PC con 64MB de RAM, por que la distro se CARGA ENTERA en los 64MB de RAM, aunque para hacerla funcionar de forma aceptable una vez cargada, es necesario disponer de algo más de RAM...

Una vez cargada la distro, puedes quitar el pendrive, y el SO sigue funcionando perfectamente... va rapidísimo. Sin instalar nada a mayores, por ejemplo, funcionan los videos de youtube, la version 5.0 incluye un navegador propio (no se si está basado en otro o no) muy muy ligero (menos intuitivo de usar que Chromium o Firefox, pero muy funcional de todas formas). La version 5.1 incluye el navegador NetSurf, tambien bastante ligero, no tan ligero como el incluido en LUPU 5.0, pero, por otro lado, mas intuitivo de usar (aunque tiene más problemas con ciertas páginas que los navegadores más conocidos).

Tanto en Puppy Linux 5.0 como en la versión 5.1, además del navegador incluído por defecto, pueden ser instalados 4 navegadores con un par de clicks de ratón: Firefox, Seamonkey, Chromium, y Opera. Del mismo modo, con un click, el usuario puede elegir un navegador predeterminado gracias a una herramienta de elección de navegador, a la que podemos acceder desde la barra de tareas.

Tendremos a un click la herramienta Puppy Setup, que nos permite el acceso inmediato a diversos programas de configuración del SO, como la red, el idioma del teclado, la zona horaria, configuración del ratón, de la tarjeta de sonido, de vídeo, impresoras (CUPS), etc.

La red se configura fácilmente: La red cableada se configura en un menú con un par de clicks de ratón, y la wifi del portátil (en el mismo menú), me resulto sumamente sencilla de configurar también, teniendo que elegir la red a la cual te conectas, el tipo de seguridad, el password de la red, y poco más. El menú de configuraciones de redes es muy intuitivo y accesible.

Dispondremos también de la herramienta Quickpet, que nos permite acceder a la instalacion de algunas de las utilidades mas populares con pocos clicks, como los navegadores ya mencionados, el reproductor VideoLanClient, el editor de video Cinelerra, el Java JRE, Thunderbird, GIMP, Audacity, Wine, Google Earth, OpenOffice, los drivers de vídeo, etc.

Además también tenemos a nuestro alcance el Puppy Package Manager, que nos permite instalar otra serie de paquetes desde el repositorio de puppy-lucid

Para finalizar, aunque la distribucion es LiveCD, nos permite, mediante un menu, instalarla facilmente en pendrives, discoduros externos, CompactFlash, discos ZIP, disquets LS120, o en un discoduro/partición del ordenador.

La distribución, literalmente, vuela en máquinas más bien modernas, y seguro que va de forma decente en máquinas con cierta antiguedad...



Actualizado a la versión 5.1.1:

Han retirado la versión 5.1 de Puppy Linux y en su lugar han publicado la versión 5.1.1
La verdad no encuentro muchas explicaciones al respecto, pero básicamente la distro se mantiene igual, o muy similar a la, ya retirada, versión 5.1. Es de suponer que será prioritariamente una actualización para solventar bugs y problemas.

La imagen nueva ISO que nos descargaremos se llama "lupu-511.iso"

Actualizado! Disponible Lucid Puppy 5.2
Puppy 5.2 AQUÍ

Descarga directa:
lupu-520.iso

8 comentarios:

Ejecutivo Koala dijo...

El unico pero que le pongo a este tipo de distros es su dificultad de instalar.

Por mas que eh seguido los pasos uno tras otro para poder arrancar desde el disco duro, ninguna vez me ah funcionado.

Eso si, ningun problema en ejecutarlo desde un CD o una USB.

Y funciona de las 1000 maravillas.

SGAN dijo...

Es curioso, yo la versión 5.1 no la instalé, la estuve probando en modo LiveCD, pero la versión 5.0 si la instalé como distro permanente en mi PC durante un tiempo, y me resultó sencilla de instalar.

Ahora mismo estoy en un portátil con Lubuntu, asi que no puedo mirarlo, y no recuerdo muy bien como era la instalación, pero recuerdo que fue sencilla, había que ir a un menú accesible desde los iconos del escritorio (el mismo menú al que hay que entrar para luego entrar en el Puppy Package Manager), y ahí una de las opciones te lleva al menu de instalación, y entre las opciones de dicha instalación (como ya dije en el análisis), esta la de instalarlo en el discoduro, junto a la de instalarla en pendrives, CF's, etc.

Anónimo dijo...

Ya no puedo aguantar mas a descargarlo, gracias por la revicion!

Anónimo dijo...

si la instalaste muchas veces yno puedes acceder es por que tal vez al final de la instalación hay que descargar el grub e instalarlo en el HDD una vez instalado al reiniciar la maquina hay queguardar los cambios de sesión y con esto quedara...

pero si alguien me ayuda acambiarle de idioma lo agradecere...

SGAN dijo...

Yo estuve mirando mucho, y la verdad no encontré forma de traducirlo, encontré en el foro de Puppy Linux unos paquetes precompilados ".pet" con idiomas, pero creo que son para Lucid Puppy Quickset... así que si lo quieres en español, primero deberías bajarte esa versión de Puppy:

http://shino.pos.to/linux/lupq/


Y luego el paquete del idioma:

http://219.75.240.235/puppy/lupq/opt/languages/

Para más información visita este link:
http://murga-linux.com/puppy/viewtopic.php?t=59691

En cuanto pueda pruebo esa edición de Puppy, a ver si realmente se puede traducir, y que diferencias puede tener a simple vista con Lucid Puppy 5.1.1

エクトル Hector Mendoza dijo...

Hola, me parece excelente el tema de promocionar distros mas livianos y demas. Tengo el siguiente problema y me gustaria que alguien me ayude en este caso. Uso regularmente Ubuntu. Por problemas de hardware (no muy potente), estoy probando con diferentes versiones de linux, como tengo varios pendrive usb, he decido instalarlos en ellos e ir probandolos. Acabo de bajar Lupu-501-iso del sitio oficial. Tengo ya varios distros en pen, pero esta vez, al tratar de crear un disco de inicio usb con esta imagen de Lupu me dice que no es un sistema de escritorio compatible por lo tanto aborta el procedimiento. el pen donde quiero introducirlo es de 1GB y la imagen tiene 128MB. Tal vez la solucion sea muy facil pero no la estoy encontrando en la red.

エクトル Hector Mendoza dijo...

Felcitaciones por el blog y promocionar a experimentar con distros mas livianas. Tengo una consulta, me encuentro en el siguiente problema. Acabo de bajar Lupuñ501.ISO. Ya tengo varios distros instalados en pendrive que uso sin problemas. En esta caso, cuando intento crear un disco usb de inicio con la utilidad de ubuntu, al seleccionar la imagen de lupu, me dice que no es un sistema de escrtorio compatible, y a continuacion aborta la tarea. el pen donde quiero grabarlo tiene 1GB y la imagen 128MB. A lo mejor es un problema minimo y facil de solucionar, pero en mi busqueda por la red no encuentro el modo de arreglarlo. Alguien me podria indicar que hacer? muchas gracias.

SGAN dijo...

No endendí muy bien la pregunta, pero lo que llego a entender, es que quiero instalar Lucid Puppy 5.1 en un Pendrive... de ser así, la mejor alternativa es que uses el propio menos que incluye Puppy Linux entre las aplicaciones de su menú, trae consigo una aplicación que te permite instalar Puppy Linux en diferentes soportes, incluido el USB, y por lo menos a mí, todo se me hizo automáticamente y sin problemas...

De todas formas he visitado la página de Puppy, y acabo de percatarme de que existe una versión más nueva, Puppy 5.2... deberías bajarte esa.

Aun no he probado la nueva 5.2, pero tuve algunos problemas con Puppy 5.1.1... me resulto imposible instalar programas que requiriesen el paquete Python-GTK (PyGTK), que no viene en los repositorios y no encontrté ninguna forma de instalarlo correctamente, siendo la única opción viable compilarlo. Tuve problemas al compilarlo pues me daba una serie de errores y no encontré donde metía la pata.

La distro funciona bien, pero en principio hay que prescindir de aplicaciones que requieren Python-GTK (como eMeSeNe, en su lugar tendrías que usar aMSN).

Espero que ese tipo de detalles se hayan corregido en Puppy 5..2, a ver si tengo tiempo para probarla uno de estos días.